Folge uns

Android

Google Play kündigt API-Voraussetzungen für Apps an – Android 9 ab Sommer

Veröffentlicht

am

Android API Header

Google hat ein paar Richtlinien für neue Apps veröffentlicht, betroffen sind grundsätzlich die im Google Play Store veröffentlichten Apps. Google macht das nicht erst seit gestern so, neue und aktualisierte Apps müssen ein bestimmtes API Level als Ziel haben. Man sorgt damit für mehr Sicherheit und eben für eine gewisse Aktualität, was die veröffentlichten Apps anbelangt.

Google Play requirements for 2019

In order to provide users with the best Android experience possible, the Google Play Console will continue to require that apps target a recent API level:

  • August 2019: New apps are required to target API level 28 (Android 9) or higher.
  • November 2019: Updates to existing apps are required to target API level 28 or higher.

Existing apps that are not receiving updates are unaffected and can continue to be downloaded from the Play Store.

Google sieht in diesem Vorgehen diverse Vorteile. Insbesondere bei Datenschutz und Sicherheit sind die Nutzer nun auf der sicheren Seite. Zudem werden keine veralteten Schnittstellen mehr angesprochen, sodass auch die Fehlerquote während der Benutzung sinkt.

Andere App-Stores auch betroffen

Google hat sogar realisieren können, dass auch andere App-Stores mit Mindestvoraussetzungen arbeiten. Man nennt im Zuge dessen Huawei, Oppo, Vivo und Xiaomi.

Over 95% of spyware we detect outside of the Play Store intentionally targets API level 22 or lower, avoiding runtime permissions even when installed on recent Android versions. To protect users from malware, and support this ecosystem initiative, Google Play Protect will warn users when they attempt to install APKs from any source that do not target a recent API level:

  • August 2019: New apps will receive warnings during installation if they do not target API level 26 or higher.
  • November 2019: New versions of existing apps will receive warnings during installation if they do not target API level 26 or higher.
  • 2020 onwards: The target API level requirement will advance annually.

Kommentare öffnen

Kommentar verfassen

Diese Website verwendet Akismet, um Spam zu reduzieren. Erfahre mehr darüber, wie deine Kommentardaten verarbeitet werden.

Beliebt